Experian Address Validation - Performance Degraded

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Dec 03, 2024 - 04:00 UTC

Monitoring

Some customers in US region may have seen slightly higher response times and latency for a period of time. This is now stabilised and we are investigating the root cause.
Posted Dec 03, 2024 - 03:22 UTC
This incident affected: Address Solutions (Experian Address Validation).