Degraded performance on Experian Address Validate

Incident Report for Experian Data Quality

Resolved

Fix has been implemented.
Posted Jun 30, 2025 - 07:57 UTC

Investigating

Some customers might be experiencing higher response times - we are investigating
Posted Jun 30, 2025 - 07:42 UTC
This incident affected: Address Solutions (Address Validation (REST v2)).