Electronic Updates Performance Degradation.

Incident Report for Experian Data Quality

Resolved

The service is now working as expected, we are monitoring closely
Posted Apr 16, 2025 - 17:03 UTC

Investigating

Some customers in Australia and New Zealand may see intermittent errors when attempting to download data. We are investigating this now.
Posted Apr 16, 2025 - 08:19 UTC
This incident affected: Other (Electronic Updates).